DPlot FAQ

From dataTaker Wiki (FAQ)

DPlot Charting Software Frequently Asked Questions

Contents

General

Is DPlot a dataTaker product?

No. DPlot is a product created and owned by Hydesoft Computing but is distributed with dataTaker data loggers because of its ability to work with dataTaker DBD files.

How can I obtain a copy of DPlot?

DPlot is included with new dataTaker data loggers and can be purchased from Hydesoft Computing but be sure to ask for the dataTaker plug in.

How do I get the latest version of DPlot?

DPlot has an update function built in, therefore the process is simple. Click Help-->Check for updates and DPlot will contact the server via the internet, download and install the new version automatically.

Usage

How do I Open DBD files?

During installation, DPlot is associated with DBD files, therefore to open a DBD file simply double-click it within Windows Explorer. Alternatively a DBD file can be dropped onto a DPlot window, which will open the file in that window.

How do I display or hide a trace?

Traces can be displayed or hidden by clicking View-->Hide Curves. This brings up a list from which traces can be selected to be hidden. Alternatively, a hide trace option is made available by right-clicking on the trace directly or by clicking the name of the trace in the legend.

Is there a zoom box?

Yes. Click the Zoom button from the toolbar and drag a box around the area of interest.

It is also possible to make this the default behaviour of the left mouse button if you click Options>General then tick the box marked Click and drag to zoom

Can I use multiple Y-Axes?

Yes. DPlot currently supports two y-axes. To add a second y-axis, right-click on the main Y-axis and select Multiple Axes from the pop up menu, this will bring up the Multiple Axes window. To enable a second Y-axis click Independent Y2.

Is it possible to view alarms using DPlot?

Yes. DPlot can be used to visualise when alarms had been triggered or reset during a recording. If a DBD file is opened and it contains alarm data, the user will be prompted whether or not to display these alarms. The TRUE state corresponds to an alarm OFF-->ON transition and the FALSE state corresponds to an alarm ON-->OFF transition. The alarms are displayed as a set of triangular markers underneath the data traces. These markers are colour-coded based on the alarm number. If the mouse pointer is hovered over an alarm marker then the corresponding alarm state, alarm text and the timestamp are displayed in a box.

NOTE: Alarms cannot be viewed if the data was exported from the logger in CSV format.

How do I view the max, min, and average for data sets?

To view statistics for a dataset, click the List Peaks button on the toolbar (or click Info-->List Peak Values). A dialog box will appear, which lists minimum and maximum amplitudes and the point at which they occur, in addition to the mean, standard deviation and standard error for each trace. The same can be accomplished for a subset of the data by clicking the List Peaks in Range button on the toolbar (or clicking Info-->List peaks within a range) and selecting a data range using the mouse cursor.

How do I view data from multiple schedules in one plot?

If you wish to plot data from multiple schedules then open the first schedule and then use file-->append for the other schedules. If the data from multiple schedules is contained in a single DBD file then each time the file is openned or appended simply select a different schedule.

The DBD file contains more than one schedule of data which was not supported in early versions of DPlot. Upgrade to version 2.2.9.3 or later. This can be done online using the Check for updates option under the help menu. Once a later version of DPlot is installed you will be able to select which schedule you wish to plot.

Can I view the raw data from within DPlot?

Yes. To do this, click the Edit Data button on the toolbar (or Edit-->Edit data from the menu). A prompt will appear asking which trace to view the data from, select the trace and click OK. The edit data points window will now appear, displaying the raw data for the selected trace

How do I export DBD data to a CSV file?

To export data (including alarms) to an Excel compatible format (CSV), click File-->Save As. A dialog box will appear which allows the data to be saved in many different formats. Select ‘Comma-separated values’ from the dropdown list and type in a filename for the CSV file to save. This file can now be opened in Excel or other spreadsheet software.

Does DPlot support opening CSV files?

Yes. Simply open a CSV file using the open dialog (File-->Open) or by dropping a CSV file onto the DPlot window. A dialog box will appear which allows you to select what traces to chart, then clock OK.

Troubleshooting

DPlot doesn't seem to open any DBD files

This is because the dataTaker plugin is not selected within DPlot. To fix this, click File-->Open then select L from the file types, and check that Datataker DBD files is selected as the current file plugin. If the dataTaker DBD plugin is not available, then please contact support so that we may send it to you.

If DPlot was installed from the original CD, then this problem should not occur as the dataTaker plugin is automatically installed and selected during installation.

My traces all have similar colours, how do I change them?

To change the trace colours, click the Colors button on the toolbar or select Options-->Colors-->Edit... from the menu. This allows you to select the trace colours and save them as defaults.

My question is not answered here, what do I do?

Please contact Hydesoft Computing directly, their current contact details can be found on their website DPLot Alternatively, if your query is specific to a dataTaker DBD file then please contact dataTaker support.

Why won't DPlot accept my registration key?

There are a small number of CD's sent out with incorrect user names printed on the label.

  • The user name should be dataTaker user nnnn where nnnn is your unique identification number.
  • If your unique identification number is less than 4 characters then it must be padded with leading zeros (i.e. If your number is 12 then enter 0012)
  • Please make sure you enter the user name correctly. dataTaker is all one word with no space between data and Taker.

Why does Dplot report "?44544454 Unknown section tag" when opening some DBD files?

The DBD file contains more than one schedule of data which was not supported in early versions of DPlot. Upgrade to version 2.2.9.3 or later. This can be done online using the Check for updates option under the help menu. With the newer version of DPlot you are able to select which schedule you wish to plot. If you wish to plot data from multiple schedules then open the first schedule and then use file-->append for the other schedules.

I can't upgrade to the full version after my trial version has expired?

If you have been running the trail version of DPlot and it has time expired you will need to uninstall the trail version before installing the full version.

Views
Personal tools